Redaguojme Firefox plėtinius, kad jei būtų suderinami naujausiomis naršyklių versijomis

Firefox

Išmoksime kaip paredaguoti priedą, kad jis būtų suderimas su naujomis (beta) Firefox naršyklės versijomis. Tiesa, tai bus tik Firefox apgaulė, tikrai nėra garantijos, jog priedas veiks korektiškai ar išvis veiks. Seniau aprašiau vieną būdą kaip tai padaryti, tačiau jo pagrindinis trūkumas, jog jis padaro visus priedus „suderinamus“ ir kai kuriais atvejais tai gali netikti.

Pirmiausia reiktų parsisiųsti plėtinį, ir čia iškart prasideda gudrybės, kadangi Mozilla Addons tanybą Jums to neleis.

add1

Tam pačiam puslapyje žemiau rasite  nuorodą į visas priedo versijas.

add2

Keliaujame nuoroda ir randame naujausią versiją, tačiau ją jau galime įsidiegti į Firefox, tačiau neskubėkite to daryti, atsisiųskite ją į kompiuterį.

add3

Atsidarykite atsisiųstą xpi failą su archyvatoriumi. Pasirinkite reaguoti (keisti arba edit) install.rdf.

add4

Failas bus atidarytas su notepad, jei archyvatoriaus nustatymuose nenurodyta ktaip.

Susirandame pažymėtas 3 eilutes.

ad9

Pirmoje nurodoma programa, nes pplėtinys gali veikti ne tik su Firefox, bet ir su Thunderbird, SeaMonkey… Antrojoje eilutejė nurodama mažiausia programos versija su kuria priedas gali veikti, o trečiojoje didžiausią, ją ir reiktų paredaguoti.

Pasikoreguojame trečią eilutę ir įrašome aukštesnę Firefox versiją.

add7

Išsaugome failą.

Archyvatorius paklaus ar atnaujinti archyvą, sutikite.

add8

Dabar telieka įdiegti plėtinį į naršyklę, tiesiog  jį(xpi failą) atsidarius per File==>Open File meniu.

O toliau viskas kaip įprastai 🙂

Tikiuosi šis įrašas Jums pravers.

Panašūs įrašai:

css.php
Bear